POST/users/{username}/copilot-spaces/{space_number}/collaborators

Add a collaborator to a Copilot Space for a user

Adds a collaborator to a specific Copilot Space owned by a user. The authenticated user must be the owner of the space or have admin access to the space.

Team collaborators are not supported for user-owned Copilot Spaces.

OAuth app tokens and personal access tokens (classic) need the user scope to use this endpoint.

  • RetriesRetries up to 2×, 500ms backoff, 30s timeout.

2 parameters · 3 body fields
usernamestringrequired
The handle for the GitHub user account.
space_numberintegerrequired
The unique identifier of the Copilot Space.
actor_typestringrequired
The type of actor (must be `User` for user-owned spaces; `Team` will be rejected).
Allowed:UserTeam
actor_identifierstringrequired
The username of the collaborator. The numeric user ID is also accepted.
rolestringrequired
The role to grant to the collaborator.
Allowed:readerwriteradmin

4 status codes
201Response
namestringoptional
emailstringoptional
loginstringrequired
idintegerrequired
node_idstringrequired
avatar_urlstringrequired
gravatar_idstringrequired
urlstringrequired
html_urlstringrequired
followers_urlstringrequired
following_urlstringrequired
gists_urlstringrequired
starred_urlstringrequired
subscriptions_urlstringrequired
organizations_urlstringrequired
repos_urlstringrequired
events_urlstringrequired
received_events_urlstringrequired
typestringrequired
site_adminbooleanrequired
starred_atstringoptional
user_view_typestringoptional
actor_typestringrequired
The collaborator actor type.
Allowed:User
rolestringrequired
The role granted to the collaborator
Allowed:readerwriteradmin
403Forbidden
messagestringoptional
documentation_urlstringoptional
urlstringoptional
statusstringoptional
404Resource not found
messagestringoptional
documentation_urlstringoptional
urlstringoptional
statusstringoptional
422Validation failed, or the endpoint has been spammed.
messagestringrequired
documentation_urlstringrequired
errorsarray<object>optional

Error handling

A 403 is returned: Forbidden. A 404 is returned: Resource not found. A 422 is returned: Validation failed, or the endpoint has been spammed.

Was this helpful?